Network Outage in the Grasselli Library & Breen Learning Center
Incident Report for John Carroll University
Resolved
This incident has been resolved.
Posted Jan 30, 2020 - 11:48 EST
Update
We are continuing to investigate this issue.
Posted Jan 30, 2020 - 11:29 EST
Investigating
Information Technology Services (ITS) is currently experiencing network issues in the Grasselli Library & Breen Learning Center.

ITS is working to quickly resolve these connection issues. If you are currently experiencing network issues, please contact the Service Desk at 216-397-3005.

Information Technology Services
sites.jcu.edu/its
216-397-3005
Posted Jan 30, 2020 - 10:55 EST
This incident affected: Network (Wired/Wireless) (Grasselli Library & Breen Learning Center).